报错代码
curl: (60) SSL certificate problem: EE certificate key too weak
More details here: https://curl.se/docs/sslcerts.html
原因分析
目标链接证书的加密强度太弱,而本地系统设置了禁止访问此类弱加密强度的链接
解决方法
将允许访问的证书种类设置成默认水平
# update-crypto-policies --set Default
curl: (60) SSL certificate problem: EE certificate key too weak
More details here: https://curl.se/docs/sslcerts.html
目标链接证书的加密强度太弱,而本地系统设置了禁止访问此类弱加密强度的链接
将允许访问的证书种类设置成默认水平
# update-crypto-policies --set Default
# chage -l mingyuzhu
configuration error - unknown item 'USERADD_CMD' (notify administrator)
configuration error - unknown item 'USERDEL_PRECMD' (notify administrator)
configuration error - unknown item 'USERDEL_POSTCMD' (notify administrator)
configuration error - unknown item 'CHARACTER_CLASS' (notify administrator)
......
# cat /var/log/messages
......
......chage[31546]: shadow: unknown configuration item 'USERADD_CMD' in '/etc/login.defs'
......chage[31546]: shadow: unknown configuration item 'USERDEL_PRECMD' in '/etc/login.defs'
......chage[31546]: shadow: unknown configuration item 'USERDEL_POSTCMD' in '/etc/login.defs'
......chage[31546]: shadow: unknown configuration item 'CHARACTER_CLASS' in '/etc/login.defs'
......
在 /etc/login.defs 文件中有不被系统支持的参数
SLES 15.7 及以上的版本不再支持以下参数:
USERADD_CMD
USERDEL_PRECMD
USERDEL_POSTCMD
CHARACTER_CLASS
将所有和报错相关的参数注释掉,例如
# vi /etc/login.defs
注释掉以下内容:
......
#USERADD_CMD /usr/sbin/useradd.local
......
#USERDEL_PRECMD /usr/sbin/userdel-pre.local
......
#USERDEL_POSTCMD /usr/sbin/userdel-post.local
......
#CHARACTER_CLASS ......
......
Problem: module php:7.2:820181215112050:76554e01.x86_64 from rhel-8-for-x86_64-appstream-rpms requires module(nginx:1.14), but none of the providers can be installed
- module nginx:1.14:820181214004940:9edba152.x86_64 from rhel-8-for-x86_64-appstream-rpms conflicts with module(nginx:1.24) provided by nginx:1.24:8100020240119085512:e155f54d.x86_64 from rhel-8-for-x86_64-appstream-rpms
- module nginx:1.24:8100020240119085512:e155f54d.x86_64 from rhel-8-for-x86_64-appstream-rpms conflicts with module(nginx:1.14) provided by nginx:1.14:820181214004940:9edba152.x86_64 from rhel-8-for-x86_64-appstream-rpms
- module nginx:1.14:8000020190830002848:f8e95b4e.x86_64 from rhel-8-for-x86_64-appstream-rpms conflicts with module(nginx:1.24) provided by nginx:1.24:8100020240119085512:e155f54d.x86_64 from rhel-8-for-x86_64-appstream-rpms
- module nginx:1.24:8100020240119085512:e155f54d.x86_64 from rhel-8-for-x86_64-appstream-rpms conflicts with module(nginx:1.14) provided by nginx:1.14:8000020190830002848:f8e95b4e.x86_64 from rhel-8-for-x86_64-appstream-rpms
- conflicting requests
Dependencies resolved.
# dnf module disable php
# dnf module reset php && dnf module enable php:7.2
(补充:这里以设置 php:7.2 模块为例)
创建这个用户时报错这个用户已经创建
删除这个用户时报错这个用户不存在
使用 id 命令检查这个用户时会显示此用户
# getent passwd -s sss mingyuzhu
(补充:这里以检查某个用户名有没有被域名占用为例)
# vi /etc/nsswitch.conf
将以下内容:
......
passwd: files systemd
......
修改为:
......
#passwd: files systemd
......
# systemctl restart sssd
# vi /etc/sssd.conf
添加以下内容:
......
[nss]
filter_users = mingyuzhu
(补充:这里以忽略 mingyuzhu 用户为例)
# systemctl restart sssd
https://access.redhat.com/solutions/3442161
某些服务没有开机自启例如 NetworkManager.service
在系统日志里可以类似 …… Job network.target/start deleted to break ordering cycle starting with …… 报错例如:
# cat /var/log/messages
Jan 1 10:09:24 server systemd[1]: network-online.target: Found ordering cycle on network.target/start
Jan 1 10:09:24 server systemd[1]: network-online.target: Found dependency on NetworkManager.service/start
Jan 1 10:09:24 server systemd[1]: network-online.target: Found dependency on basic.target/start
Jan 1 10:09:24 server systemd[1]: network-online.target: Found dependency on slices.target/start
Jan 1 10:09:24 server systemd[1]: network-online.target: Found dependency on mysql.slice/start
Jan 1 10:09:24 server systemd[1]: network-online.target: Found dependency on remote-fs.target/start
Jan 1 10:09:24 server systemd[1]: network-online.target: Found dependency on remote-fs-pre.target/start
Jan 1 10:09:24 server systemd[1]: network-online.target: Found dependency on iscsi.service/start
Jan 1 10:09:24 server systemd[1]: network-online.target: Found dependency on network-online.target/start
Jan 1 10:09:24 server systemd[1]: network-online.target: Job network.target/start deleted to break ordering cycle starting with network-online.target/start
Jan 1 10:09:24 server systemd[1]: NetworkManager-wait-online.service: Found ordering cycle on NetworkManager.service/start
Jan 1 10:09:24 server systemd[1]: NetworkManager-wait-online.service: Found dependency on basic.target/start
Jan 1 10:09:24 server systemd[1]: NetworkManager-wait-online.service: Found dependency on slices.target/start
Jan 1 10:09:24 server systemd[1]: NetworkManager-wait-online.service: Found dependency on mysql.slice/start
Jan 1 10:09:24 server systemd[1]: NetworkManager-wait-online.service: Found dependency on remote-fs.target/start
Jan 1 10:09:24 server systemd[1]: NetworkManager-wait-online.service: Found dependency on remote-fs-pre.target/start
Jan 1 10:09:24 server systemd[1]: NetworkManager-wait-online.service: Found dependency on iscsi.service/start
Jan 1 10:09:24 server systemd[1]: NetworkManager-wait-online.service: Found dependency on network-online.target/start
Jan 1 10:09:24 server systemd[1]: NetworkManager-wait-online.service: Found dependency on NetworkManager-wait-online.service/start
Jan 1 10:09:24 server systemd[1]: NetworkManager-wait-online.service: Job NetworkManager.service/start deleted to break ordering cycle starting with NetworkManager-wait-online.service/start
从案例中日志里的内容可以判断:
1) network.target/NetworkManager.service 启动
2) NetworkManager.service 作为基础服务依赖 basic.target
3) basic.target 依赖所有 slice 包括 mysql.slice
4) mysql.slice 依赖 iscsi.service/remote-fs.target/remote-fs-pre.target
5) iscsi.service/remote-fs.target/remote-fs-pre.target 依赖 network.target/NetworkManager.service
6) 系统为了防止启动时陷入死循环,systemd 报错 Job NetworkManager.service/start deleted to break ordering cycle 并放弃启动 NetworkManager.service
取消不太重要的服务的依赖要求
# vi /etc/systemd/system/mysql.slice
将以下内容:
......
Before=slices.target
Wants=-.slice
After=-.slice remote-fs.target
......
修改为:
......
Before=slices.target
Wants=-.slice
After=-.slice #remote-fs.target
......
(
补充:
1) 这里以取消使用 /etc/systemd/system/mysql.slice 文件的服务的依赖要求为例
2) 这里以注释掉 After=-.slice remote-fs.target 中的 remote-fs.target 为例
)