报错代码
curl: (60) SSL certificate problem: EE certificate key too weak
More details here: https://curl.se/docs/sslcerts.html
原因分析
目标链接证书的加密强度太弱,而本地系统设置了禁止访问此类弱加密强度的链接
解决方法
将允许访问的证书种类设置成默认水平
# update-crypto-policies --set Default
curl: (60) SSL certificate problem: EE certificate key too weak
More details here: https://curl.se/docs/sslcerts.html
目标链接证书的加密强度太弱,而本地系统设置了禁止访问此类弱加密强度的链接
将允许访问的证书种类设置成默认水平
# update-crypto-policies --set Default
# vi /etc/yum.conf
或者:
# vi /etc/dnf/dnf.conf
将部分内容修改如下:
......
keepcache = 1
# yum clean all
或者:
# dnf clean all
# yum makecache
# yum update --downloadonly
或者:
# dnf update --downloadonly
# yum -C list
或者:
# dnf -C list
# yum -C list kernel
或者:
# dnf -C list kernel
(补充:这里以显示已经缓存的 kernel 软件包为例)
# yum -C update
或者:
# dnf -C update
# vi /etc/rsyslog.conf
添加以下内容:
......
$FileOwner root
$FileGroup root
$FileCreateMode 0640
$DireCreateMode 0640
或者:
......
$FileOwner root
$FileGroup root
$Umask 0137
(补充:这里以所属主是 root、所属组是 root、文件的权限是 0640、目录的权限是 0755 为例)
如果是 RHEL 6 和 RHEL 6 之前的版本 RHEL:
# service rsyslog restart
# service auditd restart
如果是 RHEL 7 和 RHEL 7 之后版本的 RHEL 或者是 SLES:
# systemctl restart rsyslog
# service auditd restart
# chage -l mingyuzhu
configuration error - unknown item 'USERADD_CMD' (notify administrator)
configuration error - unknown item 'USERDEL_PRECMD' (notify administrator)
configuration error - unknown item 'USERDEL_POSTCMD' (notify administrator)
configuration error - unknown item 'CHARACTER_CLASS' (notify administrator)
......
# cat /var/log/messages
......
......chage[31546]: shadow: unknown configuration item 'USERADD_CMD' in '/etc/login.defs'
......chage[31546]: shadow: unknown configuration item 'USERDEL_PRECMD' in '/etc/login.defs'
......chage[31546]: shadow: unknown configuration item 'USERDEL_POSTCMD' in '/etc/login.defs'
......chage[31546]: shadow: unknown configuration item 'CHARACTER_CLASS' in '/etc/login.defs'
......
在 /etc/login.defs 文件中有不被系统支持的参数
SLES 15.7 及以上的版本不再支持以下参数:
USERADD_CMD
USERDEL_PRECMD
USERDEL_POSTCMD
CHARACTER_CLASS
将所有和报错相关的参数注释掉,例如
# vi /etc/login.defs
注释掉以下内容:
......
#USERADD_CMD /usr/sbin/useradd.local
......
#USERDEL_PRECMD /usr/sbin/userdel-pre.local
......
#USERDEL_POSTCMD /usr/sbin/userdel-post.local
......
#CHARACTER_CLASS ......
......
和 grep 命令相同
和 grep 命令相同,除了以下选项
1) –dereference-recursive 或者 -R
2) –directories 或者 -d
3) –exclude
4) –exclude-from
5) –exclude-dir
6) –include
7) –null 或者 -Z
8) –null-data 或者 -z
9) –recursive 或者 -r